View unanswered posts | View active topics It is currently Fri, 2017/11/24 8:40 am



Reply to topic  [ 9 posts ] 
OpenNotifier 2.2.1~beta-19 and LeftClock 1.0.7 can't coexist 
Author Message

Joined: Thu, 2014/08/28 2:59 pm
Posts: 9
Unread post OpenNotifier 2.2.1~beta-19 and LeftClock 1.0.7 can't coexist
Hi tateu,

I got in just in time to update my iPhone 5S from 7.1.2 to 8.4 before the signing window closes. I am very happy and thankful to see you are still carrying the torch for OpenNotifier.

I am finding there to be a conflict between OpenNotifier 2.1.1~beta-19 and LeftClock 1.0.7. If they are both installed (and "active" in iCleaner Pro, which I've been using to isolate them), the phone will not start up. The Apple logo disappears, and the screen stays completely black (still illuminated by backlight) and does nothing, and no re-spring "chime" either, until finally I am forced to restart in safe mode. Each one works fine on it's own, just not together. I hope this report can be helpful in some way!

Thanks!


Tue, 2015/08/18 10:16 pm
Profile
Site Admin

Joined: Sun, 2005/04/03 7:02 pm
Posts: 302
Location: Los Angeles, CA USA
Unread post Re: OpenNotifier 2.2.1~beta-19 and LeftClock 1.0.7 can't coe
I have them both installed. There is no conflict.


Tue, 2015/08/18 11:10 pm
Profile WWW

Joined: Thu, 2014/08/28 2:59 pm
Posts: 9
Unread post Re: OpenNotifier 2.2.1~beta-19 and LeftClock 1.0.7 can't coe
Thanks for the report. I wonder what the problem could be on my end? I did try using iCleaner Pro to disable everything except for these two plus libstatusbar and I still could not get it to start up (no chime, just black illuminated screen). Is it possible that there is a conflict with something that would not get turned off in iCleaner Pro because it is not part of mobile substrate?
Thanks!


Tue, 2015/08/18 11:18 pm
Profile
Site Admin

Joined: Sun, 2005/04/03 7:02 pm
Posts: 302
Location: Los Angeles, CA USA
Unread post Re: OpenNotifier 2.2.1~beta-19 and LeftClock 1.0.7 can't coe
There is a possibility of absolutely everything in the jailbreak world. We're all messing with things that aren't meant to be messed with. I just ran them both with everything enabled I normally use on my device. Rebooted twice, resprung twice. No issues. I can't help with an issue I can't reproduce.

There are reports of bluescreens and problems booting all over the 8.4 jailbreak scene and no one knows why.

https://www.reddit.com/r/jailbreak/sear ... r=on&t=all
https://www.reddit.com/r/jailbreak/sear ... r=on&t=all


Tue, 2015/08/18 11:28 pm
Profile WWW

Joined: Thu, 2014/08/28 2:59 pm
Posts: 9
Unread post Re: OpenNotifier 2.2.1~beta-19 and LeftClock 1.0.7 can't coe
Thanks for the feedback. Fortunately, I got it to work! I uninstalled both, then deleted both net.tateu.opennotifier.plist and net.tateu.leftclock.plist, then reinstalled both, and it now starts up with both of them enabled! I definitely prefer the combination of these two to any of the alternatives (Protean is nice, but I do still prefer ON+LC)


Tue, 2015/08/18 11:38 pm
Profile
Site Admin

Joined: Sun, 2005/04/03 7:02 pm
Posts: 302
Location: Los Angeles, CA USA
Unread post Re: OpenNotifier 2.2.1~beta-19 and LeftClock 1.0.7 can't coe
Did you delete the plists? Or keep a copy of them? If you kept a copy, can you send them to me? Maybe there is a very specific set of settings for each that caused your problem.


Wed, 2015/08/19 12:30 pm
Profile WWW

Joined: Thu, 2014/08/28 2:59 pm
Posts: 9
Unread post Re: OpenNotifier 2.2.1~beta-19 and LeftClock 1.0.7 can't coe
I always keep a copy when troublshooting :wink: I will attach and send a copy to your email (assuming I should use the forum@ address? let me know if a different address is better)

Furthermore, I managed to figure out what combination of settings can consistently recreate the problem by starting out with completely default settings and changing things one-by-one until I found the bare minimum set of conditions that lead to the issue. The attached plist files represent this bare minimum set of conditions, which is that the Alarm Icon is enabled in OpenNotifier while Enable Clock is enabled in LeftClock. If Alarm Icon is disabled, then everything works fine with or without any of the other icons enabled, and if "Enable Clock" is disabled, then everything works fine even with the Alarm Icon enabled.

Fortunately for me, I am fine to let the system handle the alarm icon, so I can leave it disabled in OpenNotifier and everything else works just the way I want it to!


Wed, 2015/08/19 3:17 pm
Profile
Site Admin

Joined: Sun, 2005/04/03 7:02 pm
Posts: 302
Location: Los Angeles, CA USA
Unread post Re: OpenNotifier 2.2.1~beta-19 and LeftClock 1.0.7 can't coe
alkalifly wrote:
I always keep a copy when troublshooting

Me too. Sadly, most people don't and it often leads to problems when they start messing with system files.

Thanks for all of this. You've been much more helpful than most users. I'll take a look at it sometime in the next few days or so.


Wed, 2015/08/19 3:25 pm
Profile WWW

Joined: Thu, 2014/08/28 2:59 pm
Posts: 9
Unread post Re: OpenNotifier 2.2.1~beta-19 and LeftClock 1.0.7 can't coe
No problem! I used to work in tech support, so I have an easy time relating when I ask others for support, and I do my best to be a good troubleshooter. And now with the updated LeftClock, the Alarm Icon can be enabled in OpenNotifier and everything is copacetic. Nice! Thanks for all the great work you do


Thu, 2015/08/20 11:04 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software